- RT-A、RT-B、RT-C をネットワーク構成図に示す通り設定し、合わせて必要な RIP の設定も行いなさい。
< RT-A >
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# host RT-A
RT-A(config)# int lo0
RT-A(config-if)# ip add 192.168.1.1 255.255.255.224
RT-A(config-if)# int f0/1
RT-A(config-if)# ip add 192.168.1.33 255.255.255.224
RT-A(config-if)# no shut
RT-A(config-if)# router rip
RT-A(config-router)# network 192.168.1.0
RT-A(config-router)# ^Z
RT-A#
< RT-B >
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# host RT-B
RT-B(config)# int f0/0
RT-B(config-if)# ip add 192.168.1.34 255.255.255.224
RT-B(config-if)# no shut
RT-B(config-if)# int lo0
RT-B(config-if)# ip add 172.16.1.2 255.255.255.0
RT-B(config-if)# int f0/1
RT-B(config-if)# ip add 172.16.2.2 255.255.255.0
RT-B(config-if)# no shut
RT-B(config-if)# router rip
RT-B(config-router)# network 192.168.1.0
RT-B(config-router)# network 172.16.0.0
RT-B(config-router)# ^Z
RT-B#
< RT-C >
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# host RT-C
RT-C(config)# int f0/0
RT-C(config-if)# ip add 172.16.2.3 255.255.255.0
RT-C(config-if)# no shut
RT-C(config-if)# int lo0
RT-C(config-if)# ip add 10.10.10.3 255.255.0.0
RT-C(config-if)# router rip
RT-C(config-router)# network 172.16.0.0
RT-C(config-router)# network 10.0.0.0
RT-C(config-router)# ^Z
RT-C#
- Lo0 のIPアドレスを使って、RT-A から RT-B の Lo0 へ ping を実行しなさい。
RT-A# ping 172.16.1.2 source 192.168.1.1 ← 192.168.1.1 が RT-A の Lo0 のIPアドレス
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
RT-A#
- Lo0 のIPアドレスを使って、RT-A から RT-C の Lo0 へ ping を実行しなさい。
RT-A# ping 10.10.10.3 source 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.3, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
RT-A#
- RT-A のルーティングテーブル (RIP) を表示させなさい。
< RT-A >
RT-A# sh ip route rip | begin Gateway
Gateway of last resort is not set
R 10.0.0.0/8 [120/2] via 192.168.1.34, 00:00:07, FastEthernet0/1
R 172.16.0.0/16 [120/1] via 192.168.1.34, 00:00:07, FastEthernet0/1
RT-A#
RT-A のルーティングテーブルでは
172.16.1.0/24 と 172.16.2.0/24 が集約されて 172.16.0.0/16 に
10.10.0.0/16 が集約されて 10.0.0.0/8に
なっています。
- RT-B のルーティングテーブル (RIP) を表示させなさい。
< RT-B >
RT-B# sh ip route rip | begin Gateway
Gateway of last resort is not set
R 10.0.0.0/8 [120/1] via 172.16.2.3, 00:00:26, FastEthernet0/1
192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
R 192.168.1.0/27 [120/1] via 192.168.1.33, 00:00:13, FastEthernet0/0
RT-B#
RT-B のルーティングテーブルでは
192.168.1.0/27 は集約されずに 192.168.1.0/27 のままに
10.10.0.0/16 は集約されて 10.0.0.0/8 に
なっています。
- RT-C のルーティングテーブル (RIP) を表示させなさい。
< RT-C >
RT-C# sh ip route rip | begin Gateway
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
R 172.16.1.0/24 [120/1] via 172.16.2.2, 00:00:02, FastEthernet0/0
R 192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:02, FastEthernet0/0
RT-C#
RT-C のルーティングテーブルでは
192.168.1.0/27 と 192.168.1.32/27 が集約されて 192.168.1.0/24 に
172.16.1.0/24 は集約されずに 172.16.1.0/24 のままに
なっています。
- RT-A、RT-B、RT-C で RIPv2 を有効にしなさい。
< RT-A >
RT-A# conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT-A(config)# router rip
RT-A(config-router)# version 2
RT-A(config-router)# ^Z
RT-A#
< RT-B >
RT-B# conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT-B(config)# router rip
RT-B(config-router)# version 2
RT-B(config-router)# ^Z
RT-B#
< RT-C >
RT-C# conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT-C(config)# router rip
RT-C(config-router)# version 2
RT-C(config-router)# ^Z
RT-C#
RIPv2 を有効にするには version 2 コマンドを実行するだけです。
- RT-A、RT-B、RT-C のルーティングテーブル (RIP) を表示させなさい。
< RT-A >
RT-A# sh ip route rip | begin Gateway
Gateway of last resort is not set
R 10.0.0.0/8 [120/2] via 192.168.1.34, 00:00:28, FastEthernet0/1
R 172.16.0.0/16 [120/1] via 192.168.1.34, 00:00:28, FastEthernet0/1
RT-A#
< RT-B >
RT-B# sh ip route rip | begin Gateway
Gateway of last resort is not set
R 10.0.0.0/8 [120/1] via 172.16.2.3, 00:00:05, FastEthernet0/1
192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
R 192.168.1.0/27 [120/1] via 192.168.1.33, 00:00:23, FastEthernet0/0
RT-B#
< RT-C >
RT-C# sh ip route rip | begin Gateway
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
R 172.16.1.0/24 [120/1] via 172.16.2.2, 00:00:12, FastEthernet0/0
R 192.168.1.0/24 [120/1] via 172.16.2.2, 00:00:12, FastEthernet0/0
RT-C#
ルーティングテーブルが RIPv1 の時と全く変わりません。
RIPv2 はサブネットマスクを RIP アップデートに含めますので、通常、今回のようにデフォルトのサブネットマスク以外を使用したネットワークの場合、RIPv1 とRIPv2 のルーティングテーブルは異なります。しかし、RIPv2 も標準でサポートしている自動集約機能によりクラスの境界で自動集約されて、今回のネットワーク構成では RIPv1 と全く同じルーティングテーブルになりました。
- RT-A で show ip protocols コマンドを実行しなさい。
< RT-A >
RT-A# sh ip protocols
*** IP Routing is NSF aware ***
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 25 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/1 2 2 ← アップデートの送受信とも v2
Loopback0 2 2 ← アップデートの送受信とも v2
Automatic network summarization is in effect ← 自動集約有効
Maximum path: 4
Routing for Networks:
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
192.168.1.34 120 00:00:12
Distance: (default is 120)
RT-A#
アップデートの送受信が v2 になったこと以外は、RIPv1 と変わりません。
- RT-A で show run コマンドを実行しなさい。
< RT-A >
RT-A# sh run | section rip
router rip
version 2
network 192.168.1.0
RT-A#
- RT-A、RT-B、RT-C で自動集約をさせないように設定しなさい。
< RT-A >
RT-A# conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT-A(config)# router rip
RT-A(config-router)# no auto-summary ← 自動集約を無効にするコマンド
RT-A(config-router)# ^Z
RT-A#
< RT-B >
RT-B# conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT-B(config)# router rip
RT-B(config-router)# no auto-summary
RT-B(config-router)# ^Z
RT-B#
< RT-C >
RT-C# conf t
Enter configuration commands, one per line. End with CNTL/Z.
RT-C(config)# router rip
RT-C(config-router)# no auto-summary
RT-C(config-router)# ^Z
RT-C#
- RT-A で show run コマンドを実行しなさい。
< RT-A >
RT-A# sh run | section rip
router rip
version 2
network 192.168.1.0
no auto-summary
RT-A#
- RT-A、RT-B、RT-C で clear ip route * コマンドを実行しなさい。
< RT-A >
RT-A# clear ip route *
RT-A#
< RT-B >
RT-B# clear ip route *
RT-B#
< RT-C >
RT-C# clear ip route *
RT-C#
clear ip route * コマンドは、現在のルーティングテーブルにあるルート情報を全て消去します。そして、再学習により、ルーティングテーブルは最新のルート情報で再構築されます。無効になった集約されたルートがルーティングテーブルから消えるまで最大240秒 (フラッシュタイマー) もかかるため、clear ip route * コマンドで強制的にルーティングテーブルを再構築させました。
- RT-A、RT-B、RT-C のルーティングテーブル (RIP) を表示させなさい。
< RT-A >
RT-A# sh ip route rip | begin Gateway
Gateway of last resort is not set
10.0.0.0/16 is subnetted, 1 subnets
R 10.10.0.0 [120/2] via 192.168.1.34, 00:00:10, FastEthernet0/1 ← 10.10.0.0/16 宛てのルート
172.16.0.0/24 is subnetted, 2 subnets
R 172.16.1.0 [120/1] via 192.168.1.34, 00:00:10, FastEthernet0/1 ← 172.16.1.0/24 宛てのルート
R 172.16.2.0 [120/1] via 192.168.1.34, 00:00:10, FastEthernet0/1 ← 172.16.2.0/24 宛てのルート
RT-A#
< RT-B >
RT-B# sh ip route rip | begin Gateway
Gateway of last resort is not set
10.0.0.0/16 is subnetted, 1 subnets
R 10.10.0.0 [120/1] via 172.16.2.3, 00:00:02, FastEthernet0/1 ← 10.10.0.0/16 宛てのルート
192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
R 192.168.1.0/27 [120/1] via 192.168.1.33, 00:00:30, FastEthernet0/0 ← 192.168.1.0/27 宛てのルート
RT-B#
< RT-C >
RT-C# sh ip route rip | begin Gateway
Gateway of last resort is not set
172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
R 172.16.1.0/24 [120/1] via 172.16.2.2, 00:00:11, FastEthernet0/0 ← 172.16.1.0/24 宛てのルート
192.168.1.0/27 is subnetted, 2 subnets
R 192.168.1.0 [120/2] via 172.16.2.2, 00:00:11, FastEthernet0/0 ← 192.168.1.0/27 宛てのルート
R 192.168.1.32 [120/1] via 172.16.2.2, 00:00:11, FastEthernet0/0 ← 192.168.1.32/27 宛てのルート
RT-C#
全てのルーティングテーブルの RIP ルートエントリが集約されずに、サブネット単位になりました。
- RT-A で show ip protocols コマンドを実行しなさい。
< RT-A >
RT-A# sh ip protocols
*** IP Routing is NSF aware ***
Routing Protocol is "rip"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Sending updates every 30 seconds, next due in 23 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Redistributing: rip
Default version control: send version 2, receive version 2
Interface Send Recv Triggered RIP Key-chain
FastEthernet0/1 2 2
Loopback0 2 2
Automatic network summarization is not in effect ← 自動集約無効
Maximum path: 4
Routing for Networks:
192.168.1.0
Routing Information Sources:
Gateway Distance Last Update
192.168.1.34 120 00:00:10
Distance: (default is 120)
RT-A#
次に、このネットワークで RIPv2 を使用したらルーティングテーブルがどう変わるかを見てみましょう。